miércoles, 18 de abril de 2018

Configurar el envío de emails con gmail o cualquier servidor smtp desde linea de comando para Routers Mikrotik

Para configurar el envío de correos electrónicos desde un router Mikrotik con gmail podemos introducir estas lineas de comando directamente en el terminal del dispositivo.


/tool e-mail set
address=smtp.gmail.com set port=587
set from=correo@gmail.com
set user=correo@gmail.com
set password=contraseña set start-tls=yes

Evidentemente si queremos podemos cambiar los parámetros para cualquier otro proveedor de correo electrónico que nos permita usar su servidor smtp.

gmail logo

Y si queremos enviar un correo electrónico de para verificar el correcto funcionamiento lo podemos hacer también en un segundo solo introduciendo la siguiente línea comando:

send to=correo@destinatario.com subject="prueba" body="prueba"


Más info en: https://wiki.mikrotik.com/wiki/Manual:Tools/email

lunes, 16 de abril de 2018

Importar y exportar access-list en routers Mikrotik por linea de comando

Para poder exportar o importar los dispositivos que están incluidos en la lista "access-list" desde el terminal de los routers Mikrotik podemos usar los siguientes comandos:


Exportar:
/ interface wireless access-list export
Exportar a archivo:
/ interface wireless access-list export file=your_access-list
Importar:
/ import your_access-list.rsc

La lista de acceso "access-list" nos permite incluir, asociado a las direcciones MAC, una breve descripción para cada dispositivo disponible y algunos otros parámetros de configuración. Lo que facilita el control de los dispositivos a la red y también nos puede ayudar a bloquear el acceso a los dispositivos no incluidos en ella de la red.

domingo, 15 de abril de 2018

Backup por linea de comandos para routers Mikrotik



Para realizar una backup por linea de comando de la configuración de los routers Mikrotik deberemos abrir una ventana de terminal, desde "Winbox>New Terminal" por ejemplo, y en el raíz del sistema de archivos ejecutaremos la siguiente linea:

export file=nombre_del_archivo

A continuación en la ruta file encontraremos el archivo de configuración con la extensión .rsc que es el script que se puede ver y modificar desde cualquier editor de texto con la configuración actual del router.

Es un proceso sencillo pero imprescindible para salvaguardar los datos de configuración de forma editable.
Nos permitirá poder restaurar de forma cómoda y si es necesario podremos, editándolo, cambiar parámetros de configuración offline.

Esto nos permita aplicar multitud de cambios solo restaurando la configuración con este archivo. Lo que minimiza las paradas de la red al reducir tiempos de mantenimiento a tan solo unos segundos.

sábado, 14 de abril de 2018

La lista de acceso en los routers Mikrotik (access-list) en 5 minutos

En este vídeo se explica someramente que es la access-list de los routers Microtik, como se hace una copia de seguridad, como se incluyen dispositivos en ella y como se quitan, como se aplica para filtrar dispositivos no deseados y darle un nivel mayor de seguridad a la red.


Acceso a un router Mikrotik mediante WinBox desde de Internet o una red externa

Desde WinBox:

  1. Haga clic en IP, Firewall y después en "Filter Rules"
  2. Haga clic en el signo + para agregar una nueva regla.
  3. Cambie "Chain" a "input"
  4. Cambie "Protocol" a "tcp".
  5. Cambie de "Dst. Port" a 8291.
  6. Haga clic en la pestaña "Action" y asegúrese de que "Action" está configurado como "accept"
  7. Haga clic en "Comment" y nómbrelo algo así como "MikroTik external access (winbox)".
  8. Haga clic en OK
  9. Mueva la nueva "Filter Rule" creada por encima de la primera regla "drop"


NOTA:
Las reglas de filtrado (Filter Rules) se ejecutan en orden. Comienzan en la parte superior y se ejecutan una tras otra. Si la nueva regla está DESPUÉS de la regla de "drop", esta no funcionará.

viernes, 28 de julio de 2017

Como crear un acceso directo con ruta relativa en Windows

Como crear un acceso directo con ruta relativa en Windows.

Cuando creamos un acceso directo este tiene una ruta absoluta del tipo "C:\carpeta\archivo.extensión" que puede ocasionar problemas si se cambia de ubicación o se encuentra en una unidad de red a la que se accede desde varios equipos.

Para evitar esto crearemos un acceso directo con ruta relativa de la siguiente forma.

  1. Creamos un acceso directo normal con el botón derecho del ratón sobre el archivo en cuestión.
  2. Modificamos en las propiedades del archivo el campo "Destino" a "%windir%\explorer.exe carpeta\archivo.extensión"
  3. Modificamos en las propiedades del archivo el campo "Iniciar en:" borrando su contenido
  4. (opcional) Cambiamos el icono por el de la aplicación o archivo para el que creamos el acceso directo.

viernes, 4 de julio de 2014

Acceso desde Internet al router de Jazztel Comtrend AR-5387un


Si no podemos acceder a la configuración del router Comtrend AR-5387un desde Internet posiblemente sea porque el firewall del router esté bloqueando el acceso desde Internet.


Para poder gestionarlo remotamente deberemos realizar los siguientes pasos:
  1. . Acceder a la página de gestión mediante la IP local del mismo
  2. . Cambiar la contraseña por defecto del usuario admin del router desde "Management>Access-Control>Passwords"
  3. . Crear una regla que nos permita el acceso desde Internet desde "Advanced Setup>Security>IP-Filtering>Incoming"
    Filter Name: REMOTE
    Interfaces: ppp0.1
    IP Version: 4
    Protocol: None
    SrcIP/ PrefixLength: IP-desde-la-que-se-accederá
    SrcPort DstIP/:
    PrefixLength:
    DstPort:
  4. .Aplicar la configuración y reiniciar el router. 


A partir de entonces ya podremos acceder al conocido router de Jazztel Comtrend AR-5387un desde Internet mediante http://IP-publica