viernes, 4 de julio de 2014

Acceso desde Internet al router de Jazztel Comtrend AR-5387un


Si no podemos acceder a la configuración del router Comtrend AR-5387un desde Internet posiblemente sea porque el firewall del router esté bloqueando el acceso desde Internet.


Para poder gestionarlo remotamente deberemos realizar los siguientes pasos:
  1. . Acceder a la página de gestión mediante la IP local del mismo
  2. . Cambiar la contraseña por defecto del usuario admin del router desde "Management>Access-Control>Passwords"
  3. . Crear una regla que nos permita el acceso desde Internet desde "Advanced Setup>Security>IP-Filtering>Incoming"
    Filter Name: REMOTE
    Interfaces: ppp0.1
    IP Version: 4
    Protocol: None
    SrcIP/ PrefixLength: IP-desde-la-que-se-accederá
    SrcPort DstIP/:
    PrefixLength:
    DstPort:
  4. .Aplicar la configuración y reiniciar el router. 


A partir de entonces ya podremos acceder al conocido router de Jazztel Comtrend AR-5387un desde Internet mediante http://IP-publica

domingo, 5 de enero de 2014

Cambiar la cache de Google Chrome de ubicación en Windows 7 y 8


Para poder cambiar la cache de Google Chrome de ubicación en Windows 7 y 8 a otro disco duro, a un disco RAM, pendrive, etc. podemos hacer un enlace simbólico con el comando MKLINK.

Como ejemplo podemos ejecutar las siguientes líneas en una ventana de símbolo del sistema con derechos de Administrador. Cambiando eso si, las rutas, por las adecuadas según la configuración del sistema.


TASKKILL /f /IM chrome.exe

RD /S /Q "C:\Users\Usuario\AppData\Local\Google\Chrome\User Data\Default\Cache\"

MD "C:\Users\Usuario\AppData\Local\Google\Chrome\User Data\Default\"

MD "R:\temp\Chrome\User Data\Default\Cache"

mklink /D "C:\Users\Usuario\AppData\Local\Google\Chrome\User Data\Default\Cache\" "R:\temp\Chrome\User Data\Default\Cache"


De esta forma en un minuto tendremos cambiada la ruta de la cache a donde queramos de forma definitiva y totalmente transparente para Chrome.

PS: Podemos ejecutar el Google Chrome de forma que coja cualquier directorio como caché desde un acceso directo, pero esto en ocasiones puede dar problemas que evitaremos usando este método.


sábado, 11 de mayo de 2013

Instalar DD-WRT desde Windows en Routers Edimax BR-6574n y Planet WNRT-630


A continuación detallo el procedimiento para instalar DD-WRT en routers Planet WNRT-630 y Edimax BR-6574n desde Windows. Que a efectos prácticos es el mismo router.


Cambiamos la IP del PC poniendo la por 192.168.1.5 (no usar la 192.168.1.6 ya que la usará el router.)

Conectamos por cable de red el router con el PC directamente desde una de las 4 bocas destinadas a los equipos cliente del router.

Desconectamos la alimentación del router y manteniendo presionado el botón WPS/Reset conectamos de nuevo la alimentación. Esperamos 10 segundos y soltamos el botón.

Esperamos 1 minuto a que el router se estabilice.

Instalamos desde activar o desactivar las características de Windows la herramienta tftp

Abrimos una ventana de MS-DOS

Nos colocamos en la carpeta que tiene la imagen de DD-WRT que queremos instalar y tecleamos el comando:

tftp -i 192.168.1.6 put image.tftp

donde image.tftp deberá ser sustituido por el nombre del firmware a instalar.

En breve nos tiene que dar como respuesta algo similar a "Transferencia correcta: 3543042 bytes en 9 segundo(s), 393671 bytes/s"

El router se reiniciará solo y desde la IP 192.168.1.1 ya podremos acceder al nuevo firmware. En caso contrario esperamos un par de minutos y lo reiniciamos de forma manual.

Con esto ya tenemos actualizado el router mediante tftp.

Nota: Para ver cual es la última versión recomendada de firmware disponible iremos a la "router database" de DD-WRT y buscaremos por BR-6574n

Más info:
http://www.dd-wrt.com/phpBB2/viewtopic.php?t=66672

domingo, 28 de abril de 2013

Una forma diferente de encontrar registros repetidos en una lista de excel, calc, etc.


Si tenemos una lista con registros repetidos que queremos localizar, además de las formas nativas incluidas en las últimas versiones de Excel, podemos usar el método de comprobar si la celda actual es igual a la anterior.

Por ejemplo en Excel podemos usar la formula
=SI(A2=A1;"REPETIDO";"")
Y nos marcará los registros repetidos




Para extender la fórmula a lo largo de la lista solo tenemos que pinchar en la esquina inferior derecha (marcada con un cuadradito) de la celda que contiene la primera formula  y estirar hacia abajo hasta el final de la lista.

Quedando así:

A =SI(A2=A1;"REPETIDO";"")
B =SI(A3=A2;"REPETIDO";"")
B =SI(A4=A3;"REPETIDO";"")
C =SI(A5=A4;"REPETIDO";"")
etc.


Luego podemos aplicar un filtro para ver más cómodamente cuales están repetidos.

Los registros repetidos que no sean contiguos no saldrán como repetidos, pero eso se soluciona simplemente seleccionando la columna y aplicando la opción Datos>Ordenar desde la barra de menú de Excel antes de aplicar la formula a toda la lista.

Nota: Esto también se puede usar en calc y otras hojas de cálculo simplemente adaptando ligeramente la fórmula en caso de que esto sea necesario.

Espero les resulte de utilidad este pequeño truco.


viernes, 8 de marzo de 2013

Formatear un disco duro en FAT32 desde Windows 8

Últimamente parece que a Microsoft no le gusta que se formateen los discos duros con sistemas de formato antiguos como el FAT32 o FAT porque estas opciones no aparecen en la herramienta de Administración de discos para Windows 8, Windows Server 2008, etc.
Por lo tanto para poder realizar el formateo de un disco duro con estos formatos nos tenemos que ir a la linea de comandos y desde allí usar el comando "format"

Por ejemplo para formatear una unidad a FAT32 teclearemos en una ventana de DOS con permisos de administrador lo siguiente:

format /FS:FAT32 X:

Nota: X: es la unidad de disco a formatear.

martes, 12 de febrero de 2013

Mover la caché de Java


En ocasiones, para mejorar el rendimiento de un sistema o para optimizar el uso de espacio puede ser necesario mover la caché de Java a otra unidad. Podemos hacerlo simplemente siguiendo estos pasos.

Desde el Panel de control de Java
Buscar>Java>Archivos temporales de Internet y cambiar la ruta desde ahí

En ocasiones el sistema no nos permitirá realizar el cambio desde el panel de control por lo que tendremos que hacerlo directamente de forma manual.

De forma manual

Abrimos el archivo:
%SYSTEMDRIVE%\Users\%USERNAME%\AppData\LocalLow\Sun\Java\Deployment\deployment.properties

Y lo editaremos añadiendo esta linea o la remplazaremos si ya existiese.

deployment.user.cachedir=R\:\\temp\\JavaCache

Este ejemplo nos ubicaría la caché de java en "R:\temp\JavaCache".

Podemos comprobar que se ha efectuado el cambio con éxito en el Panel de control de Java.



Visto en iambiased.wordpress.com
Nota: probado y funcionando correctamente también en Windows 8